Facebook and Instagram features temporarily down
Incident Report for AgoraPulse
Resolved
This incident has been resolved.
Posted 4 months ago. May 05, 2018 - 02:21 CEST
Update
The review of our app by Facebook has been completed, all the permissions and features to manage Facebook pages and Instagram accounts should be now back to normal.

Sorry for the inconvenience and thank you for your patience.
Posted 4 months ago. May 05, 2018 - 02:21 CEST
Update
Due to recent Facebook Platform changes and required app reviews, some permissions to manage Facebook pages and Instagram accounts are temporarily disabled. (App review in progress).

Because of this incident, you might face one of these following errors:

1. Facebook
1.1 Inability to add a Facebook page
Problem: You do not see a list of your Facebook pages.
Status: We temporarily removed the option to add a Facebook page as we temporarily don't have the required permission to do so.

1.2 Inability to add a Facebook competitor
Problem: An error message appears if you try to add a competitor page to your report grid.
Status: We're awaiting the required Facebook permission to perform this action.

1.3. Facebook Inbox reply: misleading error message
Problem: An error message ("An unknown error occurred") was displayed when you replied to an item, even if your reply was correctly published.
Status: FIXED ✅

1.4 Facebook publishing issue
Problem: Duplicate scheduled/queued items published
Status: FIX READY, should be released this afternoon (CET time) 🔧

1.5 Facebook inbox: private conversation synchronization issue
Problem: Private conversations were not synchronizing.
Status: FIXED ✅

1.6 Facebook synchronization
Problem: Some specific items are not synchronizing such as Facebook Reviews (Inbox), Album photo comments (Inbox), Video comments (inbox) and Facebook mentions (Monitoring).
Status: We're awaiting Facebook permission approval to perform these calls on their API. 📝

2. INSTAGRAM

2.1 Instagram inbox and monitoring
Problem: Comments (inbox) and listening searches were not synchronizing.
Status: FIXED ✅

2.2 Instagram Inbox reply: misleading error message
Problem: An error message ("Cannot invoke method toLong() on null object") was displayed when you replied to an item, even if your reply was correctly published.
Status: FIXED ✅


We're very sorry for the inconvenience and are working hard to restore full functionality as quickly as possible.

We will update this incident as soon as we have new information.
Posted 4 months ago. May 04, 2018 - 15:25 CEST
Identified
Due to recent Facebook Platform changes and required app reviews, some permissions to manage Facebook pages and Instagram accounts are temporarily disabled (App review in progress).

Because of this incident, you might face one of these following errors:

1. Facebook
- unable to add a Facebook page: we have to remove this option as we don't have anymore the required permission to do so.
- unable to add a Facebook competitor:
- Facebook Inbox and publishing are misleading: comments and posts are well published but you'll probably see an error message ( "An unknown error occurred") . Don't worry, content has been published.
- Some specific items are not synchronized: Facebook reviews (Inbox), Album photo's comments (Inbox), Facebook mentions (Monitoring).

2. Instagram
- Instagram inbox and listening are not updated: we can't synchronize your comments and your listening searches
- Instagram reply feature is working but you might see an error message while replying ("Cannot invoke method toLong() on null object"). Don't worry, content has been published.

We're very sorry for the inconvenience and are working hard to restore full functionality as quickly as possible.
We will update this incident as soon as we have new information.
Posted 4 months ago. May 04, 2018 - 11:53 CEST
Update
Some of our permissions to manage Facebook pages and Instagram accounts are still temporarily disabled.
We're in touch with Facebook direct support to re-activate these permissions.
Because of this incident, you might face one of these following errors:
1. Facebook
- unable to add a Facebook page
- unable to add a Facebook competitor
- Facebook inbox and publishing: "An unknown error occurred" while trying to reply to a Facebook comment or publish a Facebook post -- even though the reply/post has been published on Facebook.

2. Instagram
- Instagram inbox and listening are not updated: we can't synchronize your comments and your listening searches
- Instagram inbox reply: "Cannot invoke method toLong() on null object" while trying to reply to a Instagram comment -- even though the reply has been published on Instagram.
Posted 4 months ago. May 04, 2018 - 10:16 CEST
Investigating
Some of our permissions to manage Facebook pages and Instagram accounts have been temporarily disabled.
We're in touch with Facebook direct support to re-activate these permissions.
Because of this incident, you might face one of these following errors:
- unable to add a Facebook page
- unable to add a Facebook competitor
- "An unknown error occurred" while trying to reply to a Facebook comment or publish a Facebook post -- even though the reply/post has been published on Facebook.
- "Cannot invoke method toLong() on null object" while trying to reply to a Instagram comment -- even though the reply has been published on Instagram.

We're very sorry for the inconvenience and are working hard to restore full functionality as quickly as possible.
Posted 4 months ago. May 03, 2018 - 22:37 CEST
This incident affected: Manager.