We are facing technical difficulties, the tool is not working as expected at the moment

Incident Report for Agorapulse

Resolved

This incident has been resolved
Posted Jul 01, 2025 - 10:20 CEST

Update

We are continuing to investigate this issue.
Posted Jul 01, 2025 - 10:05 CEST

Investigating

The tool is not working as expected at the moment, general degraded performance. We are currently investigating the issue.
Posted Jul 01, 2025 - 10:05 CEST
This incident affected: Web Application (app.agorapulse.com).