Twitter/X posts failing to publish (images/videos)

Incident Report for Agorapulse

Resolved

The fix to prevent post failures on our end due to Twitter/X system issues is working as expected.
Posted Jun 04, 2025 - 17:11 CEST

Identified

Twitter/X has acknowledged issues with their API (see: https://docs.x.com/status#). We've implemented a workaround to help prevent post failures on our end until their service is operating normally.
Posted May 28, 2025 - 22:10 CEST

Investigating

We’re currently investigating an issue causing image and video posts for Twitter/X to fail with the error: “Upload initialization failed”. We’re sorry for the trouble and will share updates as we learn more.
Posted May 28, 2025 - 20:54 CEST
This incident affected: Publishing & Data Processing (Scheduled posts publishing).