Google outages affecting Google My Business and YouTube

Incident Report for Agorapulse

Resolved

The issues affecting publishing and inbox replies on Google Business Profile and YouTube have now been fixed. This was due to a widespread Google outage that has since been resolved. We appreciate your patience!
Posted Jun 13, 2025 - 00:58 CEST

Identified

We're currently seeing issues with publishing and inbox replies for Google My Business and YouTube. This is due to widespread outages affecting Google and other major online services. We're monitoring the situation closely.
Posted Jun 12, 2025 - 21:59 CEST
This incident affected: Publishing & Data Processing (Conversations data processing (Inbox & Listening), Scheduled posts publishing).