Facebook and Instagram Changes - 4/4/18
Incident Report for AgoraPulse
Resolved
This bug is now resolved.

1. Impossible to synchronize private messages for pages added after April 4
We're allowed to synchronize private conversations for your pages: to make sure we have the required permission to do so, please follow these steps:
- visit the following link https://app.agorapulse.com/connect/facebook
- click on "list my pages"
- accept the permission " Access your Facebook Pages' messages"
- you're all set! You can go back to your page inbox, refresh your browser page and you should get next private conversations on a real time basis

2. Impossible to search and mention a Facebook page
We removed this option, waiting for a new permission to perform this action. More info here: http://support.agorapulse.com/article/show/55140-is-it-possible-to-tag-mention-a-page-or-an-account-in-a-post-or-comment

Thanks for your patience
Posted 8 months ago. May 05, 2018 - 07:31 CEST
Identified
Facebook decided to change the way developers access data, as you can read here: https://developers.facebook.com/blog/post/2018/04/04/facebook-api-platform-product-changes/

Some of these breaking changes are impacting Agorapulse:
1. New users are now able to add their Facebook pages. They used to face the error message "Platform Access Disabled: Access temporarily disabled due to changes to the Facebook Platform". This bug is fixed. That being said, we're technically not allowed to synchronize private messages for these new pages.

This bug is only affecting users who signed up to Agorapulse after Facebook breaking changes (April 4)
We're still working on a fix to be able to synchronize private messages for all our users pages, regardless their signup date.

2. It's still impossible to search and mention a Facebook page within the publishing and replying views (as the Search API has been deprecated). This bug is affecting all our users, regardless their signup date.
As far as we know, there is no technical workaround to perform this action: we're in touch with Facebook teams to make sure we didn't miss any info.

We will continue to update this list as functionality issues are resolved and/or uncovered.
Thanks for your patience
Posted 9 months ago. Apr 05, 2018 - 15:14 CEST
Investigating
Facebook decided to change the way developers access data, as you can read here: https://developers.facebook.com/blog/post/2018/04/04/facebook-api-platform-product-changes/

Some of these breaking changes are impacting Agorapulse:
- new users can't add their Facebook pages (Platform Access Disabled: Access temporarily disabled due to changes to the Facebook Platform)
- impossible to search and mention a Facebook page within the publishing and replying view (as the Search API has been deprecated)

We will continue to update this list as functionality issues are resolved and/or uncovered.
Thanks for your patience
Posted 9 months ago. Apr 05, 2018 - 09:53 CEST